Minimum system requirements for using Online Services
  • Standard ADSL internet connection
  • Any modern browser version less than four years old, e.g., Internet Explorer 8, latest stable version of Google Chrome, latest stable version of Mozilla Firefox
  •